Bronco Fix    
Bronco Fix    
 


Home   Gallery   Tech   Glove Box   For Sale
302 1977 Sport Nearly stock is bucking/hesitating at low rpm

 
Post new topic   Reply to topic    Bronco Fix Forum Index :: Drivetrain and Suspension
View previous topic :: View next topic  
Author Message
irclausen
Bfix "What's a Bronco?"
Bfix


Joined: 29 May 2017
Posts: 3
Location: Washington State

PostPosted: Mon May 29, 2017 11:11 pm    Post subject: 302 1977 Sport Nearly stock is bucking/hesitating at low rpm Reply with quote

Whew where to start.

I've had this bronco for 17 years it was my first vehicle at 15 years old and have never had any major issues.

1977 Bronco Sport uncut and as far as I know stock.

302 engine with as far as I know the original carb (confirmed motorcraft 2150)

I'm a novice mechanic with a lot of interest in this vehicle.

Recently the bronco has started "bucking" at low rpms (like I have to press really hard on the brake, and she really wants to go). Upon releasing the brake it's pretty anti-climactic. If I hit the gas there is plenty of power, but when on the brake it feels like she really wants to go.

There is a lot of history in 17 years happy to share but will start with most recent changes:

Running terrible, messed with the carb mixture screws and idle (likely a bad first choice)

Then did/replaced the following:

-Seafoamed
-Spark plugs and cables
-Ignition Coil
-Ignition Control Module (ran much better after this likely combo of plugs and ICM)
-Removed totally rusted and leaking muffler and replace with a cherry bomb (thrush).
-Bought a vacuum gauge to try and tune the carb (started at 1.5 turns out on mixture screws and 700rpm, tweaked for max vacuum)
-Suspect vacuum leak on the choke pull down (waiting for part to replace)
-Removed choke pull down and plugged line

Still experiencing the "bucking"

_________________
1977 Bronco Sport (302 nearly stock)
Back to top
View user's profile Send private message
Stan
BFix Locked and Loaded
BFix Locked and Loaded


Joined: 29 Jun 2004
Posts: 3603
Location: Boring Or

PostPosted: Tue May 30, 2017 6:56 am    Post subject: Reply with quote

Do you have a power brake booster ? Do you have a C4 transmission?
Both have areas for potential vacuum leaks . If you have the PB booster check it for leaks and leak down and also the vacuum hose going to it.
Check the vacuum line and fittings coming the C-4

_________________
When you come to a fork in the road - take it
Homer - " Facts are meaningless . You could use facts to prove anything that's even remotely true."
Back to top
View user's profile Send private message
DirtDonk
BFix Locked and Loaded
BFix Locked and Loaded


Joined: 27 Jul 2003
Posts: 2742
Location: San Jose, CA

PostPosted: Tue May 30, 2017 10:11 pm    Post subject: Reply with quote

Also the new muffler might be breathing a little too much for a '77 rig. Not just a Bronco thing, the manufacturers were falling all over themselves jetting things as lean as they could get and making the ignitions perform as good as they could to ignite the harder-to-burn lean mixtures. Opening up the exhaust with a better breathing setup might have put the mixture into the lean area by a bit too much, and you're experiencing the consequences. Just a guess, but it could be the case.
Was this a WA truck all it's life, or was it originally a CA truck? If a CA calibration, it might have been even leaner to start with. Ditto if it was originally sold to a high-altitude location.

The mixture screws are just for setting idle mixtures though, so have only a very minimal effect on total air/fuel mix. The majority comes from the main jets and you'd have to install larger ones inside the carb.

Did the vacuum tubes get put back on the same way they came off? Just wondering if the distributor's vacuum advance hoses got mixed around or left off. Would usually go through many different sections with temperature controlled vacuum switches, but much of that stuff gets removed in areas where inspections are not mandatory. How's your "smog stuff" condition? All there, or all gone?

Have you checked for vacuum leaks using some sort of spray? Whether a semi-flammable like carburetor cleaner, to just water in a spray bottle.

Good luck.

Paul

_________________
'71 Bronco - 302 4v
3.5" WH/Skyjacker Lift
33 x 11.50 x15 Thornbirds on 15x7 Enkei's
Kayline soft top
Hanson bumpers
Dual batteries, Large 1G alt.

WWW.WILDHORSES4X4.COM Mr. Green
Back to top
View user's profile Send private message Visit poster's website
irclausen
Bfix "What's a Bronco?"
Bfix


Joined: 29 May 2017
Posts: 3
Location: Washington State

PostPosted: Wed May 31, 2017 7:43 pm    Post subject: Reply with quote

Thanks for the replies Stan and DD.

Here are some answers to questions:

Brake Booster = Yes
C4 Transmission = Yes

I bought the truck in WA and I believe it was originally sold in WA. I moved to CA for about 6 years and had to have a Cat installed when I moved down. I'm don't remember having to adjust the carb at that time, but was also not doing any of the work myself then either.

I've got the new choke pull down installed now and gave the carb a cleaning while I had the air filter off.

As far as the emissions stuff I'm going to have to figure out what might have been their originally or added later, sounds like some research for me there.

I'll inspect the Brake Booster and Tranny next as well as do some spray testing. I suspecting more and more a vacuum leak. Hard to tell with the engine running but I think I might be able to hear it. Any suggestions on what a strong/good vacuum reading should be for this setup? With and idle in park at just under 1000rpm I'm reading about 5 in.

Thanks again for the support!
[img]https://goo.gl/photos/Rn9uZDoEy4UpgyBa9[/img]

_________________
1977 Bronco Sport (302 nearly stock)
Back to top
View user's profile Send private message
Stan
BFix Locked and Loaded
BFix Locked and Loaded


Joined: 29 Jun 2004
Posts: 3603
Location: Boring Or

PostPosted: Thu Jun 01, 2017 6:07 am    Post subject: Reply with quote

Where did you take/get the 5 in vacuum reading ?
That's pretty low even for " race motors " - if that reading is correct. Mine run 18 - 21 inches so I would look for a leak or move the gauge and get a reading from somewhere else

_________________
When you come to a fork in the road - take it
Homer - " Facts are meaningless . You could use facts to prove anything that's even remotely true."
Back to top
View user's profile Send private message
DirtDonk
BFix Locked and Loaded
BFix Locked and Loaded


Joined: 27 Jul 2003
Posts: 2742
Location: San Jose, CA

PostPosted: Mon Jun 05, 2017 4:23 pm    Post subject: Reply with quote

Exactly. My '71 was in the 18-21 range as well. A good healthy stockish engine should have at least 16 but be more towards 20 unless there really is a combustion issue, or weak cylinders and bad compression, or bad ignition timing. Which are all "combustion issues" anyway.
Even your '77 with lower compression originally should still run at least at that 15/16 I would think. Perhaps some of your distributor's advance mechanism has gone wonky?

If you took your reading off of the "ported" vacuum fitting then the 5 should have been closer to zero instead. Try another port and see if you get at least 15 and stable. If the needle is flopping all over the place then you either have a leak, or a bigger problem such as a valve-job in your future.

Paul

_________________
'71 Bronco - 302 4v
3.5" WH/Skyjacker Lift
33 x 11.50 x15 Thornbirds on 15x7 Enkei's
Kayline soft top
Hanson bumpers
Dual batteries, Large 1G alt.

WWW.WILDHORSES4X4.COM Mr. Green
Back to top
View user's profile Send private message Visit poster's website
irclausen
Bfix "What's a Bronco?"
Bfix


Joined: 29 May 2017
Posts: 3
Location: Washington State

PostPosted: Tue Jun 06, 2017 3:04 pm    Post subject: Reply with quote

Thanks for the help guys.

I was taking the reading by the distributor because it was the most accessible, not sure if that was a valid place to be taking it. I never got it to go over 5 without increasing RPMs.

I did find that 2 of the vacuum plugs near the back of the carb were failing and there was a bad hose between the carb and choke pull down. I replaced all those and re-went through setting the idle and mixture screws, taking into consideration that I might need to err on the rich side based on the changes to the exhaust.

She is running great now no bucking. Cheers!

_________________
1977 Bronco Sport (302 nearly stock)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Bronco Fix Forum Index :: Drivetrain and Suspension All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum

Brought to you by The Bronco Horde and Vintage Bronco